May 26, 2017, 03:34:59 PM
Welcome, Guest. Please login or register.

If you are not part of the solution...You are part of the precipitate.

Author Topic: need HELPPPPPP  (Read 810 times)

Offline wermaxta

  • Prospect
  • *
  • Posts: 27
  • Internets: +0/-5
need HELPPPPPP
« on: July 05, 2015, 10:05:08 AM »
My os is kali linux
when i type apt-get install beef-xss i got this message
The following packages have unmet dependencies:
 beef-xss : Depends: ruby-dm-serializer but it is not installable
            Depends: ruby-qr4r but it is not installable
            Depends: ruby-rubydns (>= 0.7.0) but it is not installable
            Depends: ruby-geoip but it is not installable
E: Unable to correct problems, you have held broken packages.
how to install this packages.
Thank you

ch3rn0byl

  • Guest
Re: need HELPPPPPP
« Reply #1 on: July 05, 2015, 11:03:42 AM »
beef works fine in kali 1.1.0c vm.
try apt-get install -f
if that doesn't work, dude just clone it from github! last update was 4 hours ago.
If you read the INSTALL.txt for beef, you'll see that you need to:
apt-get install libsqlite3-dev sqlite3 sqlite3-doc
then try again.

Offline wermaxta

  • Prospect
  • *
  • Posts: 27
  • Internets: +0/-5
Re: need HELPPPPPP
« Reply #2 on: July 05, 2015, 12:08:20 PM »
with apt-get install -f i get this
root@kali:~# apt-get install -f ruby-dm-serializer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ruby-dm-serializer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ruby-dm-serializer' has no installation candidate

i found this packages here git://git.kali.org/packages/ruby-dm-serializer.git i download it but i don't know how to install it
thank you

ch3rn0byl

  • Guest
Re: need HELPPPPPP
« Reply #3 on: July 05, 2015, 12:34:47 PM »
with apt-get install -f i get this
root@kali:~# apt-get install -f ruby-dm-serializer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ruby-dm-serializer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ruby-dm-serializer' has no installation candidate

i found this packages here git://git.kali.org/packages/ruby-dm-serializer.git i download it but i don't know how to install it
thank you
how about just apt-get -f install...or just clone from github

Offline H4v0K

  • Administrator
  • Elite
  • *****
  • Posts: 1016
  • Internets: +986/-1
Re: need HELPPPPPP
« Reply #4 on: July 06, 2015, 04:31:41 AM »
Beef is already installed in kali

Offline b4b3w

  • s!nCe 1995
  • Top Hat Member
  • Experienced
  • ********
  • Posts: 150
  • Internets: +10/-1
Re: need HELPPPPPP
« Reply #5 on: July 13, 2015, 11:50:29 PM »
type in your console as root or sudo
Code: [Select]
dpkg-reconfigure beef-xxs
service postgresql start
service mysql start
service beef-xxs start
open your browser
Code: [Select]
iceweasel 127.0.0.1:3000
the beef-xss conf can you find here
Code: [Select]
/etc/beef-xss/config.yaml

and here the git or installation help:
Code: [Select]
https://github.com/beefproject/beef/wiki/Installation
BUT THIS is CORRECT beef-xss IS Standard INSTALLED ON KALI ;D
have fun and a nice day
« Last Edit: July 14, 2015, 02:36:40 AM by b4b3w »
Security is an Illusion
the Matrix has you...