October 18, 2017, 06:53:16 PM
Welcome, Guest. Please login or register.

If you are not part of the solution...You are part of the precipitate.

Author Topic: Reaver install  (Read 4369 times)

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Reaver install
« on: September 26, 2013, 06:53:13 AM »
Someone can help me?
I get this error on reaver install in ubuntu 12.04:

configure: creating ./config.status
config.status: creating Makefile
sed: -e expression #1, char 358: unknown option to `s'
mistery@MisteryOS:~reaver-1.4/src$ make
make: *** No targets.  Stop.
mistery@MisteryOS:~reaver-1.4/src$

Same error in reaver 0.3,0.2,0.1...

10x

Offline d??????????4????????????r???????k?????????????c???????????a?

  • Experienced
  • ***
  • Posts: 224
  • Internets: +89/-1
Re: Reaver install
« Reply #1 on: September 26, 2013, 07:06:12 AM »
according to this: https://www.youtube.com/watch?v=gtwm7RfAG4g

you just wget the tar file
untar
cd into the directory
cd src
./configure
make
make install

sorry if you already knew this. sometimes it helps to remove everything and start fresh

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #2 on: September 26, 2013, 07:17:46 AM »
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless$ cd reaver-1.4/
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4$ ls
docs  src
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4$ cd src/
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4/src$ ls
80211.c       builder.h     cracker.h  exchange.c  iface.h  libwps       pins.c     session.c  sigint.h  utils       wpsmon.c
80211.h       common        crc.c      exchange.h  init.c   lwe          pins.h     session.h  sql.c     wps         wpsmon.h
argsparser.c  configure     crc.h      globule.c   init.h   Makefile.in  reaver.db  sigalrm.c  sql.h     wpscrack.c
argsparser.h  configure.ac  crypto     globule.h   keys.c   misc.c       send.c     sigalrm.h  test      wpscrack.h
builder.c     cracker.c     defs.h     iface.c     keys.h   misc.h       send.h     sigint.c   tls       wps.h
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4/src$ ./configure
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for pcap_open_live in -lpcap... yes
checking for sqlite3_open in -lsqlite3... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for stdlib.h... (cached) yes
checking for stdint.h... (cached) yes
checking for string.h... (cached) yes
checking pcap.h usability... yes
checking pcap.h presence... yes
checking for pcap.h... yes
checking sqlite3.h usability... yes
checking sqlite3.h presence... yes
checking for sqlite3.h... yes
configure: creating ./config.status
config.status: creating Makefile
sed: -e expression #1, char 358: unknown option to `s'
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4/src$ make
make: *** No targets.  Stop.
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4/src$ sudo make install
make: *** No rule to make target `install'.  Stop.
mistery@MisteryOS:~/HackTools/Wireless&comunicationsTools/Wireless/reaver-1.4/src$



Same thing...:(
« Last Edit: September 26, 2013, 07:19:19 AM by misterteo »

Offline d??????????4????????????r???????k?????????????c???????????a?

  • Experienced
  • ***
  • Posts: 224
  • Internets: +89/-1
Re: Reaver install
« Reply #3 on: September 26, 2013, 07:26:37 AM »
I know it doesnt help any, but why are you installing pentesting tools on a general use OS? this will be the first of innumerable problems that you will have with most pentesting tools in ubuntu.

There is a pentest version of ubuntu called backbox, you may be able to add the repo's from that to your ubuntu, but I would really just download a Kali iso and run it in a VM, save yourself so much hassle.

I think there are even some guides to making an ubuntu pentest distro.

I just don't see the point, ubuntu is not for hacking.

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #4 on: September 26, 2013, 07:39:04 AM »
Is not the first time when I install reaver and aircrack-ng suite in UBUNTU ! Every time it work`s !
But not now.:(
Is just reaver...
And KALI...I use Backtrack from version 3...but now...is ugly,most tools are outdated and useless...
People use just metasploit,armitage and Wi-Fi tools,all the rest are in addition....
Anyway...I have my personal distro,with tools what I use...this is the best,with what are you use...
Thank you!
« Last Edit: September 26, 2013, 07:47:31 AM by misterteo »

ch3rn0byl

  • Guest
Re: Reaver install
« Reply #5 on: September 26, 2013, 08:02:49 AM »
Do you have libpcap-dev and libsqlite3-dev installed?

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #6 on: September 26, 2013, 08:12:55 AM »
Yes

mistery@MisteryOS:~$ sudo apt-get install libpcap-dev
[sudo] password for mistery:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpcap-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
mistery@MisteryOS:~$ sudo apt-get install libsqlite3-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libsqlite3-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
mistery@MisteryOS:~$

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #7 on: September 26, 2013, 09:13:17 AM »
I have build-essential in latest version...(that is my problem,no missing library) but I can`t install it!
Seems to be a script error,but,same error in all versions?I try`it all versions just for this,to see if is the script problem.But I have the same error.

ch3rn0byl

  • Guest
Re: Reaver install
« Reply #8 on: September 26, 2013, 09:20:17 AM »
remove reaver, then do it all over again:
wget http://reaver-wps.googlecode.com/fil...ver-1.4.tar.gz
tar -xvzf reaver-1.4.tar.gz
cd reaver-1.4/src/
./configure
make
sudo make install

if that doesnt work...not to sure what to tell you :/

« Last Edit: September 26, 2013, 09:34:40 AM by ch3rn0byl »

Offline d??????????4????????????r???????k?????????????c???????????a?

  • Experienced
  • ***
  • Posts: 224
  • Internets: +89/-1
Re: Reaver install
« Reply #9 on: September 26, 2013, 10:09:52 AM »
Is not the first time when I install reaver and aircrack-ng suite in UBUNTU ! Every time it work`s !
But not now.:(
Is just reaver...
And KALI...I use Backtrack from version 3...but now...is ugly,most tools are outdated and useless...
People use just metasploit,armitage and Wi-Fi tools,all the rest are in addition....
Anyway...I have my personal distro,with tools what I use...this is the best,with what are you use...
Thank you!

Hi,
  No-one with any sense uses backtrack. It is deprecated and there will never be any updates ever again.

Use Kali Linux. (the new backtrack)

I see your point about there are only a few good tools you need for pentesting.
I guess metasploit, sqlmap, nmap, beef, burpsuite, wireshark, sslstrip, dsniff, reaver and aircrack-ng is all most people need. I prefer having everything I want to learn about in one place.

Still, if you are having problems installing reaver I can see many many problems for you if you insist on making your ubuntu into a pentesting distro.

'Keep your family and business completely separated" - Biggie

Good Luck

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #10 on: September 26, 2013, 11:08:24 AM »
I don`t use anymore BackTrack,I know they don`t offer any support for that version.
Just I don`t like KALI.
I meant BackTrack was better, faster and more beautiful than KALI.
Debian is slow.
Soon I will try to make a pentest distro (amateur thing) from RedHat OS.(I know is fastest distro).

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #11 on: September 26, 2013, 11:12:49 AM »
remove reaver, then do it all over again:
wget http://reaver-wps.googlecode.com/fil...ver-1.4.tar.gz
tar -xvzf reaver-1.4.tar.gz
cd reaver-1.4/src/
./configure
make
sudo make install

if that doesnt work...not to sure what to tell you :/

I made that thing for 5-6 times.(I`m old in pentest tools,I have my own SSH bruteforce made by me...and is working well),so,I`m not really a noob in linux and other things.This error is weird...never seen before.

Offline d??????????4????????????r???????k?????????????c???????????a?

  • Experienced
  • ***
  • Posts: 224
  • Internets: +89/-1
Re: Reaver install
« Reply #12 on: September 26, 2013, 11:19:30 AM »
well if we look at the error we can see

sed: -e expression #1, char 358: unknown option to `s'


so it looks like a sed expression is going wrong somewhere, looks like it doesn't know what to do with option `s'.
maybe you can check the script and make a workaround..

Offline nullgoon

  • Prospect
  • *
  • Posts: 9
  • Internets: +0/-0
  • GCIH
Re: Reaver install
« Reply #13 on: September 26, 2013, 11:23:08 AM »
well if we look at the error we can see

sed: -e expression #1, char 358: unknown option to `s'


so it looks like a sed expression is going wrong somewhere, looks like it doesn't know what to do with option `s'.
maybe you can check the script and make a workaround..

I agree:  character # 358 in either the makefile or make itself...  the inner workings of gcc are a little over my head, for me to be much more help than that.

Offline misterteo

  • Prospect
  • *
  • Posts: 19
  • Internets: +1/-0
Re: Reaver install
« Reply #14 on: September 26, 2013, 11:26:50 AM »
well if we look at the error we can see

sed: -e expression #1, char 358: unknown option to `s'


so it looks like a sed expression is going wrong somewhere, looks like it doesn't know what to do with option `s'.
maybe you can check the script and make a workaround..
THIS is the problem! I tried older versions too (reaver 1.0.4 is latest and I tried also 1.0.2 1.0.3 even 1.0.1,error is the same) just to see if is the script the problem.But,I have the same error (if is an error this).
I know,is look like a script error.I know.But to ALL versions of reaver?;)
Anyway....