February 23, 2018, 04:50:11 AM
Welcome, Guest. Please login or register.

There are two rules for success: #1 Never Tell Everything You Know.

Author Topic: 3.13 has been released  (Read 1789 times)

Offline zer0

  • Prospect
  • *
  • Posts: 9
  • Internets: +0/-1
  • Security Through Fundemental Understanding Cert
3.13 has been released
« on: January 18, 2014, 10:42:37 AM »
http://www.backbox.org/downloads

Downloading now. Don't think I've looked at it in some time.

Offline D4rk-50ld13r

  • Top Hat Member
  • Elite
  • ********
  • Posts: 877
  • Internets: +189/-0
  • I will hack for beer.
    • http://www.ghostsec.org/
Re: 3.13 has been released
« Reply #1 on: January 18, 2014, 11:27:45 AM »
downloaded and tested live . waste of time , nothing new as usual !
negative channel-1 glitch still there . ( I know that compat-wireless is a closed project and kernels from 3.10 are not patched for this error ! i dont see why they upgraded the kernel !!)
Metasploit with no connection to database.  ( same here , they will insist on starting the services and connect manually ! they could have saved us some time by automating it , Rapid7 did already ).
If you sat a monkey down in front of a keyboard, the first thing typed would be
a unix command.

Offline ZEROF

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 225
  • Internets: +45/-1
    • Pentester
Re: 3.13 has been released
« Reply #2 on: February 04, 2014, 01:59:36 AM »
D4rk-50ld13r, what you are talking about?

Any professional pentester will know how to start postgresql if they need msf to use database. And i can propose few solution as well, i use next:

update-rc.d postgresql enable

And you are done. About backports, we are working on our own patched drivers to resolve issue with -1 channel, but if you are using most popular wifi cracking adapters you will not have any issue.

« Last Edit: February 04, 2014, 02:11:45 AM by ZEROF »

Offline ZEROF

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 225
  • Internets: +45/-1
    • Pentester
Re: 3.13 has been released
« Reply #3 on: February 04, 2014, 07:50:18 AM »
Hi Luke,

Thank you for sharing this information with me, i will check what is going on. I'm using some cheap adapter and i don't have that issue, but i assure you that i will do all my best to resolve other people issue with -1 channel.

Thank you for reporting this to me. Thanks to D4rk-50ld13r as well.

Offline An0n-Gh0st

  • Prospect
  • *
  • Posts: 30
  • Internets: +5/-6
Re: 3.13 has been released
« Reply #4 on: March 23, 2014, 07:37:56 PM »
Hi Luke,

Thank you for sharing this information with me, i will check what is going on. I'm using some cheap adapter and i don't have that issue, but i assure you that i will do all my best to resolve other people issue with -1 channel.

Thank you for reporting this to me. Thanks to D4rk-50ld13r as well.
hello ZEROF , i also got that error on backbox 3.13 but fixed by installing linux-backports following backbox official wiki here
http://wiki.backbox.org/index.php/Compat-drivers_aircrack_patched
i am using ALFA AWUS036NHA
its driver is atheros 9271 ath9k
thanks to backbox team :)
« Last Edit: March 23, 2014, 07:39:34 PM by An0n-Gh0st »

Offline GalaxyNinja

  • Global Moderator
  • Elite
  • *****
  • Posts: 1734
  • Internets: +96/-0
  • My password is **********
Re: 3.13 has been released
« Reply #5 on: March 23, 2014, 08:07:53 PM »
downloaded and tested live . waste of time , nothing new as usual !

Play nice now... ZER0F doesn't diss your distros...
A computer is only as strong as its user! -R4v3n

Offline ZEROF

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 225
  • Internets: +45/-1
    • Pentester
Re: 3.13 has been released
« Reply #6 on: March 23, 2014, 11:49:30 PM »
Hi THC,

An0n-Gh0st it's not n00bs solution and i would like to have simple solution for it. Most new users will not check our wiki and second problem is that you need to get good compact-wireless version to wake up your card. I think that i have idea how to resolve some cards issue, but my idea can't work for all adapters.

Let's say you can give me full step by step tutorial how you made your card working, I can make script that can do the job. But problem of this solution is that i can't give you any guarantee that script will work in the future. And as you know, not so many people will share their solution with me (most of them forget how they patched drivers etc..).

Why we use this not n00b solution? Because some drivers are supported with kernel, and other need to be patched. It's a Linux reality, not only BackBox Linux community issue. What we have today are people that don't understand source of this problem :

Quote
D4rk-50ld13r, what you are talking about?
negative channel-1 glitch still there . ( I know that compat-wireless is a closed project and kernels from 3.10 are not patched for this error ! i dont see why they upgraded the kernel !!)

True and not true, but what D4rk don't know (maybe) we can use compact-wireless drivers with new kernel as well (kernel needs them, it's not the other way around), and second part is that Linux(s) Torvalds supported backports (i don't know if backports solution is his idea, but I heard that from few friendly geeks). Backports will replace compact drivers and maybe this can bring some good news for new kernel users (from kernel 3.10). Kernel version have nothing with patched drivers, drivers needs patch for aircrack, and compact drivers are for normal users with older and some new adapters.

I checked and tested backports, but for now only 4 stable versions around  (who wants to try them https://backports.wiki.kernel.org/index.php/Main_Page). Now i hope that my response explained true problematic. And i'm sorry for all problems caused to D4rk-50ld13r :). I can understand your frustration i was in same situation before, i learned and learned from other dudes from this world.

GalaxyNinja, one more time, thank you for all your support and time.
« Last Edit: March 23, 2014, 11:58:09 PM by ZEROF »