October 20, 2017, 04:06:35 PM
Welcome, Guest. Please login or register.

When in doubt...WPS!

Author Topic: fixed error -1  (Read 2230 times)

Offline 3rd3y3

  • Top Hat Member
  • Enthusiast
  • ********
  • Posts: 60
  • Internets: +5/-0
fixed error -1
« on: May 26, 2014, 05:13:21 PM »
For those that may not know. The aircrack error that's been plaguing many people including myself have found a solution with google fu. I installed 1.05 then upgraded to 1.07. If you have 1.07 already then it may work off the bat. But Killing the process Network Manager made the error go away at least on my setup so when you type

airmon-ng start wlan0 (for example) kill the Network Manger PID then try and run the airodump-ng and deauth
wh1te tux with the hat to match.....

ch3rn0byl

  • Guest
Re: fixed error -1
« Reply #1 on: May 26, 2014, 07:49:58 PM »
hey just curious, i didnt see it in the official kali downloads...where did you get it?
I looked it up right now but i saw what they did to it and that it wont be out yet? im so confused :/
I read it on here http://cyberattacknews.wordpress.com/2014/04/30/kalilinux1-0-7/

Edit: Nvm...I dist-upgraded and it took me to kernel 3.14 hahaha. Should've done taht before ask haha!!
« Last Edit: May 27, 2014, 05:32:04 AM by ch3rn0byl »

Offline R4v3N

  • Administrator
  • Super Elite
  • *****
  • Posts: 3693
  • Internets: +160/-1
  • The googles and the metasploits...
    • Top-Hat-Sec
Re: fixed error -1
« Reply #2 on: May 26, 2014, 08:38:50 PM »
Just curious but when you talk about the error.. You are not connected to wifi right when your trying to scan?

Offline Malachai

  • Top Hat Member
  • Super Elite
  • ********
  • Posts: 2805
  • Internets: +18/-7
  • #!/bin/sh Day/Night (Grey Hat)
Re: fixed error -1
« Reply #3 on: May 26, 2014, 10:56:42 PM »
I know when I get the error message is when i scan a network, and collecting the packages.

I can't believe it's been this long and they haven't fixed this issue.
** Dont' judge me! **

*//
  Hope that Firewall works because your SCREWED  
  //*

Offline 3rd3y3

  • Top Hat Member
  • Enthusiast
  • ********
  • Posts: 60
  • Internets: +5/-0
Re: fixed error -1
« Reply #4 on: May 27, 2014, 10:55:42 AM »
@R4ven no sir not connected to wifi but onboard wifi was scanning. By killing that process the error went away and my alfa card is able to do it's thing.
« Last Edit: May 27, 2014, 11:03:57 AM by 3rd3y3 »
wh1te tux with the hat to match.....

Offline 0E 800

  • If something can corrupt you, you're corrupted already.
  • Top Hat Member
  • Elite
  • ********
  • Posts: 961
  • Internets: +154/-0
  • ??? ???????? ?s ?? ??c?c??-???
Re: fixed error -1
« Reply #5 on: May 27, 2014, 04:52:54 PM »
Just wanted to comment on my findings:

  Installed Kali, updated, and dist-upgraded. Pretty sure im on kernel 3.14.

While wlan0 was connected to the internet, I tried capturing on mon0/wlan1 to which I got the -1 error.

I then ran 'airmon-ng check kill' which disconnected wlan0 from the internet. However, when I tried capturing on mon0/wlan1 I no longer got the -1 error.

So maybe it is network manager or just having another wireless interface in use that causes the -1 error.

+1
"He who passes not his days in the realm of dreams is the slave of the days."

Offline R4v3N

  • Administrator
  • Super Elite
  • *****
  • Posts: 3693
  • Internets: +160/-1
  • The googles and the metasploits...
    • Top-Hat-Sec
Re: fixed error -1
« Reply #6 on: May 27, 2014, 05:59:26 PM »
Interesting find... I wonder if there is a difference if using wicd or gnome net manager. Ill have to look into this the next few days.

ch3rn0byl

  • Guest
Re: fixed error -1
« Reply #7 on: May 27, 2014, 07:32:59 PM »
One thing i noticed too was the "readme.md" isn't in the setoolkit when you press the '6' option. just throwing that out there as well. i have bleeding edge so not sure if thats why

Offline outofstep

  • Top Hat Member
  • Enthusiast
  • ********
  • Posts: 85
  • Internets: +19/-2
    • Dorkfeast
Re: fixed error -1
« Reply #8 on: March 23, 2015, 01:04:02 PM »
Has this been fixed?

Offline D4rk-50ld13r

  • Top Hat Member
  • Elite
  • ********
  • Posts: 877
  • Internets: +189/-0
  • I will hack for beer.
    • http://www.ghostsec.org/
Re: fixed error -1
« Reply #9 on: March 23, 2015, 02:33:31 PM »
Has this been fixed?
Hi

with the latest kernels , there is no patch available , and if someone advises you to re-compile the kernel with some kind
of nonsense , is a waste of time.
the only way to avoid the -1 error is to disable you network manager.
to do that , just right click on the network manager icon and untick the top option : " enable networking"
when you done , tick it back on.
If you sat a monkey down in front of a keyboard, the first thing typed would be
a unix command.

Offline 0E 800

  • If something can corrupt you, you're corrupted already.
  • Top Hat Member
  • Elite
  • ********
  • Posts: 961
  • Internets: +154/-0
  • ??? ???????? ?s ?? ??c?c??-???
Re: fixed error -1
« Reply #10 on: March 23, 2015, 03:13:59 PM »
In kali i just remove network manager and use wicd instead.

No more issues.
"He who passes not his days in the realm of dreams is the slave of the days."

Offline Grey-Matter

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 112
  • Internets: +57/-0
Re: fixed error -1
« Reply #11 on: May 25, 2015, 03:53:33 AM »
I know this thread is a little old, but i figured i'd mention this for any1 who has this issue in the future. The -1 error in aircrack is caused by wlanx being up at the same time as monx.

You shouldn't need to disable NetworkManager. Just ifconfig wlanx down.

If you need to run airodump while running deauth's, as long as you have airodump pointed at the same target or channel you're deauthing on, you should be fine since it's a channel error.

If you wanna run an airodump that's channel hopping, just run airmon-ng twice and use the seperate interfaces.

I know this issue is kinda dead now since the newest aircrack puts wlanx into monitor mode instead of adding a virtual monx. But i know alot of people (including myself) have downgraded it to fix the incompatibilities wlanxmon causes with some scripts and programs.

ch3rn0byl

  • Guest
Re: fixed error -1
« Reply #12 on: May 25, 2015, 08:29:19 AM »
But i know alot of people (including myself) have downgraded it to fix the incompatibilities wlanxmon causes with some scripts and programs.

and what incompatibilities are they?? becuase i have not personally encountered any?

Offline zerocool

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 223
  • Internets: +26/-3
Re: fixed error -1
« Reply #13 on: May 25, 2015, 08:50:37 AM »
But i know alot of people (including myself) have downgraded it to fix the incompatibilities wlanxmon causes with some scripts and programs.

and what incompatibilities are they?? becuase i have not personally encountered any?

There is a few script's it does mess with but i'm sure they will get fixed in time.


Offline Grey-Matter

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 112
  • Internets: +57/-0
Re: fixed error -1
« Reply #14 on: May 25, 2015, 07:54:33 PM »
Alot of scripts aren't coded to recognize wlanxmon. Frankenscript is a great example. It needs both wlanx and monx to even open

Also, might be a coincidence, but wash broke for me on 3 different kali installs recently. It would just show the columns with no results. When i downgraded aircrack it worked again in all 3 instances.

Basically it just caused alot of glitchy behavior in alot wireless stuff for me. I'm sure the aircrack guys know what their doing, and there's a good reason for them to change things the way they did. But not all the tools that I mess with are updated alot. Mostly scripts and gui's...