October 20, 2017, 04:21:35 PM
Welcome, Guest. Please login or register.

You Did *NOT* Just Win a Nigerian Lottery...

Author Topic: Installing Teamviewer in Kali Rolling  (Read 2390 times)

Offline Grey-Matter

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 112
  • Internets: +57/-0
Installing Teamviewer in Kali Rolling
« on: March 19, 2016, 03:36:42 AM »
++UPDATE 0916+++++
So after i reinstalled it like i talked about in my other post, i went to use it yeserday, and apt musta snuck another uninstall past me during a big upgrade or something. So to put an end to this libpng  nonsense, i just grabbed the libpng12-0:i386 package from HERE.
Did an apt-get update/upgrade, dpkg -i libpng12-0_1.2.50-2+deb8u2_i386.deb, then reinstalled teamviewer again with dpkg -i. No errors or anything, just installed and worked. Keep in mind im x64 and didn't alter my native libpng, i just installed this one seperately. No Conflicts.
++++++++++++++++

Sup everybody. I just went thru this last night and it's kind of a PITA, so figured i'd post it

source: https://forums.kali.org/showthread.php?30124-Installing-Teamviewer-11-on-Kali-rolling-x64

 Download teamviewer_11.0.53191_i386.deb (or whatever the newest i386 version is when u read this) from http://www.teamviewer.com/en/download/linux/

if you don't have the i386 libs installed.... "dpkg --add-architecture i386"

apt-get update && apt-get upgrade

apt-get install libc6:i386 libgcc1:i386 libasound2:i386 libfreetype6:i386 zlib1g:i386 libsm6:i386 libxdamage1:i386 libxext6:i386 libxfixes3:i386 libxrandr2:i386 libxrender1:i386 libxtst6:i386 libxinerama1:i386 graphicsmagick adwaita-icon-theme libgtk-3-0 libjpeg62-turbo libdbus-1-3 libexpat1 libfontconfig1 libjpeg62

Ignore the error about the libjpeg dependencies

apt-get -f install

dpkg -i teamviewer_11.0.53191_i386.deb

more errors....

apt-get -f install

done


i just grabbed this from the source and put it here in case anybody else here needed it. all creds go to the source.

enjoy
« Last Edit: September 22, 2016, 02:07:54 PM by Grey-Matter »

Offline jtesla

  • Prospect
  • *
  • Posts: 3
  • Internets: +0/-0
Re: Installing Teamviewer in Kali Rolling
« Reply #1 on: August 30, 2016, 01:59:50 AM »
Not worked with me with latest Rolling edition! When i run apt-get -f install it just remove teamviewer packages!

Offline Grey-Matter

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 112
  • Internets: +57/-0
Re: Installing Teamviewer in Kali Rolling
« Reply #2 on: September 04, 2016, 10:15:16 AM »
So i did have to reinstall, but i'd already gone thru the original setup with all those other packages. But assuming you downloaded the new teamviewer, teamviewer_11.0.57095_i386.deb, and u got stuck at the same error i did. It's a version issue wth libpng. It wants libpng12:386 for some reason and we have libpng16-6:i386.

 dpkg --force-depends -i teamviewer_11.0.57095_i386.deb

It worked for me and i now have the new teamviewer installed.  Im  not telling you to use --force-depends, and saying that its safe and great, but its installed :)

So that command's just gonna ignore the dependency issue, and leave libpng as it is.

Offline jtesla

  • Prospect
  • *
  • Posts: 3
  • Internets: +0/-0
Re: Installing Teamviewer in Kali Rolling
« Reply #3 on: December 10, 2016, 05:23:35 AM »
I installed yesterday teamviewer 12 to kali rolling with no issues! So who have any issues try it!