October 20, 2017, 04:17:08 PM
Welcome, Guest. Please login or register.

"640 K ought to be enough for anybody." -- Bill Gates

Author Topic: Insanity framework problem  (Read 1392 times)

Offline ErSecco

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 17
  • Internets: +0/-1
Insanity framework problem
« on: February 13, 2017, 10:10:01 PM »
Hi guys! I've installed a new kali distro 2016.2
Installed this framework from git clone
And get the error:
Err:module:import_dll library python27 (which is needed by C:\\Phyton27\phyton.exe
 Heeelp :'(
« Last Edit: February 13, 2017, 10:11:42 PM by ErSecco »
Estimate yourself and you will be estimated

Offline ch3rn0byl

  • Top Hat Member
  • Experienced
  • ********
  • Posts: 187
  • Internets: +1337/-0
  • Grumpy Old Man with Mounds of Salt
Re: Insanuty framework problem
« Reply #1 on: February 13, 2017, 10:11:44 PM »
And?

What are you going to do to fix it??
The quieter you become, the more you are unlikely to sound stupid.

Offline ErSecco

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 17
  • Internets: +0/-1
Re: Insanity framework problem
« Reply #2 on: February 13, 2017, 10:44:50 PM »
I tried to search in google before ask here ...but dont found same answer...I'n not an expert of linux
Estimate yourself and you will be estimated

Offline Amonsec

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 49
  • Internets: +36/-0
  • 1336 working to become 1337
Re: Insanity framework problem
« Reply #3 on: February 14, 2017, 01:21:22 AM »
Lulze.
Your error are really explicit, you don't have python installed on your computer. 
Two choice:

#1 - This framework run only under Windows.
#2 - You need to install python2 https://www.python.org/ftp/python/2.7.13/Python-2.7.13.tar.xz

Btw if you are in the second possibility, you didn't use Kali but windows, cauz kali got tons of python libraries (version 2 and 3).
« Last Edit: February 14, 2017, 02:07:08 AM by _amonsec »
"A computer is only as good as it's user" - R4V3N
OSCP (2017)

Offline ErSecco

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 17
  • Internets: +0/-1
Re: Insanity framework problem
« Reply #4 on: February 14, 2017, 03:51:00 AM »
When I run script to install this framork he must install wine and python and all dependencies. I've seen a window installation of python27...but I'll try install a new version of python as you sad. Tnx.
Estimate yourself and you will be estimated

Offline Amonsec

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 49
  • Internets: +36/-0
  • 1336 working to become 1337
Re: Insanity framework problem
« Reply #5 on: February 14, 2017, 04:18:23 AM »
Oooh ok you use wine.

So you need to install into wine Python 2 with this link:
#Windows x86 MSI
https://www.python.org/ftp/python/2.7.13/python-2.7.13.msi

#Windows x86-64 MSI
https://www.python.org/ftp/python/2.7.13/python-2.7.13.amd64.msi

And all dependencies of course.
"A computer is only as good as it's user" - R4V3N
OSCP (2017)

Offline ErSecco

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 17
  • Internets: +0/-1
Re: Insanity framework problem
« Reply #6 on: February 14, 2017, 07:59:21 AM »
How I can to do it into wine?
Must I to copy python into wine folder and run install?
Estimate yourself and you will be estimated

Offline Amonsec

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 49
  • Internets: +36/-0
  • 1336 working to become 1337
Re: Insanity framework problem
« Reply #7 on: February 16, 2017, 02:13:22 AM »
# For x86 wine
Code: [Select]
wget https://www.python.org/ftp/python/2.7.13/python-2.7.13.msi
wine msiexec /i python-2.7.13.msi

# For x64 wine
Code: [Select]
wget https://www.python.org/ftp/python/2.7.13/python-2.7.13.amd64.msi
wine msiexec /i python-2.7.13.amd64.msi

More informations can be found here: https://wiki.winehq.org/Msiexec
"A computer is only as good as it's user" - R4V3N
OSCP (2017)

Offline ErSecco

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 17
  • Internets: +0/-1
Re: Insanity framework problem
« Reply #8 on: February 16, 2017, 04:09:35 AM »
thank you so mutch!
Estimate yourself and you will be estimated

Offline Amonsec

  • Top Hat Member
  • Prospect
  • ********
  • Posts: 49
  • Internets: +36/-0
  • 1336 working to become 1337
Re: Insanity framework problem
« Reply #9 on: February 16, 2017, 06:05:17 AM »
Cauz I have tons of Java classes to compile  and my Intelij are slow like a dead pidgin I have enough time to fully guide you in this "Insane" installation.

Insanity framework require tow python libraries to run. VCForPython27 (C/C++ compiler) and pypiwin32.

# VCForPython27
Code: [Select]
wget https://download.microsoft.com/download/7/9/6/796EF2E4-801B-4FC4-AB28-B59FBF6D907B/VCForPython27.msi
wine msiexec /i VCForPython27.msi

# pypiwin32
Code: [Select]
cd ~/.wine/drive_c/Python26
wine python.exe Scripts/pip.exe install pyinstaller
pip install pypiwin32

That work in my kali distro.
Enjoy and have fun. ;)

_amonsec
"A computer is only as good as it's user" - R4V3N
OSCP (2017)